Bug 76352 - CSSCanvasValue can't be renamed, enforce this at compile-time.
Summary: CSSCanvasValue can't be renamed, enforce this at compile-time.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andreas Kling
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 18:05 PST by Andreas Kling
Modified: 2012-01-16 05:00 PST (History)
2 users (show)

See Also:


Attachments
Patch (2.72 KB, patch)
2012-01-15 18:09 PST, Andreas Kling
koivisto: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2012-01-15 18:05:59 PST
Instead of having CSSCanvasValue::setName(), the constructor should take the name as an argument.
Comment 1 Andreas Kling 2012-01-15 18:09:48 PST
Created attachment 122578 [details]
Patch
Comment 2 Antti Koivisto 2012-01-16 03:56:24 PST
Comment on attachment 122578 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=122578&action=review

> Source/WebCore/css/CSSParser.cpp:6454
>      CSSParserValue* a = args->current();
>      if (!a || a->unit != CSSPrimitiveValue::CSS_IDENT)

Maybe use a more descriptive name than 'a' since you are here.

> Source/WebCore/css/CSSParser.cpp:6457
> -    canvas = result;
> +
> +    canvas = CSSCanvasValue::create(a->string);

I wouldn't add an empty line here.
Comment 3 Andreas Kling 2012-01-16 05:00:50 PST
Committed r105056: <http://trac.webkit.org/changeset/105056>