Bug 132160 - [iOS WebKit2] RemoteLayerTreeDrawingArea should force CA to garbage collect surfaces.
Summary: [iOS WebKit2] RemoteLayerTreeDrawingArea should force CA to garbage collect s...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andreas Kling
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-24 18:12 PDT by Andreas Kling
Modified: 2014-04-24 23:29 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.85 KB, patch)
2014-04-24 18:20 PDT, Andreas Kling
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2014-04-24 18:12:34 PDT
Add gratuitous flush for <rdar://problem/16110687>
Comment 1 Andreas Kling 2014-04-24 18:20:50 PDT
Created attachment 230125 [details]
Patch
Comment 2 Tim Horton 2014-04-24 18:27:18 PDT
Comment on attachment 230125 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=230125&action=review

> Source/WebKit2/WebProcess/WebPage/mac/RemoteLayerTreeDrawingArea.mm:288
> +    [CATransaction begin];

I wonder if it's better to do this in didUpdate() instead; we're more likely to actually do something more immediately useful then, because by that point we would (ideally but not always) have pushed the new front surfaces to CA.
Comment 3 Andreas Kling 2014-04-24 23:26:18 PDT
(In reply to comment #2)
> (From update of attachment 230125 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=230125&action=review
> 
> > Source/WebKit2/WebProcess/WebPage/mac/RemoteLayerTreeDrawingArea.mm:288
> > +    [CATransaction begin];
> 
> I wonder if it's better to do this in didUpdate() instead; we're more likely to actually do something more immediately useful then, because by that point we would (ideally but not always) have pushed the new front surfaces to CA.

All right. Will move the "logic" there instead.
Comment 4 Andreas Kling 2014-04-24 23:29:13 PDT
Committed r167792: <http://trac.webkit.org/changeset/167792>