Bug 137042 - Renamed DebuggerCallFrameScope to DebuggerPausedScope
Summary: Renamed DebuggerCallFrameScope to DebuggerPausedScope
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-23 13:42 PDT by Mark Lam
Modified: 2014-09-23 14:24 PDT (History)
1 user (show)

See Also:


Attachments
the patch. (3.59 KB, patch)
2014-09-23 13:49 PDT, Mark Lam
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2014-09-23 13:42:14 PDT
DebuggerPausedScope is a better name for this data structure because it is meant for tracking the period within which the debugger is paused, and doing clean ups after the pause ends.
Comment 1 Mark Lam 2014-09-23 13:49:06 PDT
Created attachment 238566 [details]
the patch.
Comment 2 Michael Saboff 2014-09-23 14:16:28 PDT
Comment on attachment 238566 [details]
the patch.

rs=me
Comment 3 Mark Lam 2014-09-23 14:17:09 PDT
Comment on attachment 238566 [details]
the patch.

Thanks for the review.
Comment 4 WebKit Commit Bot 2014-09-23 14:24:12 PDT
Comment on attachment 238566 [details]
the patch.

Clearing flags on attachment: 238566

Committed r173892: <http://trac.webkit.org/changeset/173892>
Comment 5 WebKit Commit Bot 2014-09-23 14:24:14 PDT
All reviewed patches have been landed.  Closing bug.