Bug 43448 - [Qt] [QtTestBrowser] Clean up static and global menu state controls
Summary: [Qt] [QtTestBrowser] Clean up static and global menu state controls
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Antonio Gomes
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2010-08-03 15:02 PDT by Antonio Gomes
Modified: 2010-08-04 13:32 PDT (History)
2 users (show)

See Also:


Attachments
(committed with r64673, r=hausmann|kenneth) patch v1 (24.05 KB, patch)
2010-08-04 09:13 PDT, Antonio Gomes
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Gomes 2010-08-03 15:02:57 PDT
The main idea is to have a LauncherData class (as a POD) to suply LauncherWindow class with the data it needs.

All static and global related classes would go away in favor of that.

Patch coming ...
Comment 1 Antonio Gomes 2010-08-04 09:13:35 PDT
Created attachment 63457 [details]
(committed with r64673, r=hausmann|kenneth) patch v1

After LauncherWindow class was refactored out of from main.cpp, all global variables that were anging in main.cpp became temporarily public static class members of newly added LauncherWindow class. This design was not properly handling the initial purpose of the global variables: newly created launcher windows should inherit the settings of the originating one.
    
In order to properly fix the problem, this patch introduces a LauncherData class, as a POD. It comprises all data needed to handling the goal described above.
Comment 2 Kenneth Rohde Christiansen 2010-08-04 09:47:45 PDT
Comment on attachment 63457 [details]
(committed with r64673, r=hausmann|kenneth) patch v1

Why not just make a settings object?
Comment 3 Simon Hausmann 2010-08-04 12:47:09 PDT
Comment on attachment 63457 [details]
(committed with r64673, r=hausmann|kenneth) patch v1

Looks like a nice cleanup :)

You could also call it LauncherConfiguration or *Config instead of the generic "Data" :)
Comment 4 Antonio Gomes 2010-08-04 13:05:54 PDT
(In reply to comment #3)
> (From update of attachment 63457 [details])
> Looks like a nice cleanup :)
> 
> You could also call it LauncherConfiguration or *Config instead of the generic "Data" :)

Kenneth also suggested WindowOptions. What do you think?
Comment 5 Antonio Gomes 2010-08-04 13:31:52 PDT
Comment on attachment 63457 [details]
(committed with r64673, r=hausmann|kenneth) patch v1

Clearing flags on attachment: 63457

Committed r64673: <http://trac.webkit.org/changeset/r64673>