Bug 49373 - [Qt] Add an API for informing the actual visible contents rect to WebCore
Summary: [Qt] Add an API for informing the actual visible contents rect to WebCore
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Kenneth Rohde Christiansen
URL:
Keywords:
Depends on:
Blocks: 43852
  Show dependency treegraph
 
Reported: 2010-11-11 02:20 PST by Kenneth Rohde Christiansen
Modified: 2011-01-10 12:21 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.87 KB, patch)
2010-11-11 02:21 PST, Kenneth Rohde Christiansen
no flags Details | Formatted Diff | Diff
Patch (2.88 KB, patch)
2010-11-11 03:47 PST, Kenneth Rohde Christiansen
kling: review+
kling: commit-queue-
Details | Formatted Diff | Diff
Fix for def file for symbian winscw (8.04 KB, patch)
2011-01-10 11:41 PST, Misha
kenneth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Rohde Christiansen 2010-11-11 02:20:07 PST
Used in combination with tiling and resizesToContents.
Comment 1 Kenneth Rohde Christiansen 2010-11-11 02:21:27 PST
Created attachment 73592 [details]
Patch
Comment 2 Early Warning System Bot 2010-11-11 02:34:44 PST
Attachment 73592 [details] did not build on qt:
Build output: http://queues.webkit.org/results/5517080
Comment 3 Andreas Kling 2010-11-11 03:13:19 PST
Comment on attachment 73592 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=73592&action=review

> WebKit/qt/Api/qwebpage.h:283
> +    void informVisibleContentsRect(const QRect& rect) const;

I don't like this name at all, can we find a better word than "inform"?

setVisibleContentsRect?
forceVisibleContentsRect?
overrideVisibleContentsRect?
Comment 4 Kenneth Rohde Christiansen 2010-11-11 03:47:13 PST
Created attachment 73595 [details]
Patch

You win!
Comment 5 Andreas Kling 2010-11-11 03:54:23 PST
Comment on attachment 73595 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=73595&action=review

r=me, I'll land it for you (once the WebCore change is in) with fixed ChangeLog.

> WebKit/qt/ChangeLog:9
> +        (QWebPage::informVisibleContentsRect):

Somebody forgot to regen the ChangeLog ;)
Comment 6 Early Warning System Bot 2010-11-11 03:56:52 PST
Attachment 73595 [details] did not build on qt:
Build output: http://queues.webkit.org/results/5460099
Comment 7 Andreas Kling 2010-11-11 04:47:05 PST
Committed r71806: <http://trac.webkit.org/changeset/71806>
Comment 8 Ademar Reis 2010-11-16 12:46:45 PST
What about updating the symbian .def files with this new API?
(I don't know or have the tools necessary to update the .def files)
Comment 9 Misha 2011-01-10 11:41:44 PST
Created attachment 78418 [details]
Fix for def file for symbian winscw

I updated .def file for symbian winscw build. ARM build looks ok.
Comment 10 Kenneth Rohde Christiansen 2011-01-10 11:47:01 PST
Comment on attachment 78418 [details]
Fix for def file for symbian winscw

What does this ABSENT mean? The method was removed from the branch?
Comment 11 Kenneth Rohde Christiansen 2011-01-10 11:47:42 PST
(In reply to comment #10)
> (From update of attachment 78418 [details])
> What does this ABSENT mean? The method was removed from the branch?

I mean ViewportConfiguration was renamed long ago, can't those lines be removed instead? just wondering...
Comment 12 Laszlo Gombos 2011-01-10 12:19:28 PST
Proposed patch looks good to me for 2.1 (and likely for 2.2); not for trunk obviously. r=me.

Kenneth, ABSENT is a simple way to ensure that there are no holes in the ordinal numbers - otherwise one would have to reuse the ordinal numbers for new symbols, which could be confusing for clients.
Comment 13 Kenneth Rohde Christiansen 2011-01-10 12:21:30 PST
OK, thanks for the explanation!